<!doctype html > <!--[if IE 8]><html class="ie8" lang="en-US"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en-US"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US"> <!--<![endif]--><head><style id="aoatfcss" media="all">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</style><link rel="stylesheet" media="print" href="https://wallstreetwindow.com/wp-content/cache/autoptimize/css/autoptimize_21efd3d3dce2b896661c40ebb25c5849.css" onload="this.onload=null;this.media='all';" /><noscript id="aonoscrcss"><link media="all" href="https://wallstreetwindow.com/wp-content/cache/autoptimize/css/autoptimize_21efd3d3dce2b896661c40ebb25c5849.css" rel="stylesheet" /></noscript><title>Big Tech Mounting Big-Money Fight to Defeat to Corporate Antitrust Bill &#8211; Andrea Germanos | WallStreetWindow.com</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://wallstreetwindow.com/xmlrpc.php" /> <script type="text/javascript">!function(){var e={};e.g=function(){if("object"==typeof globalThis)return globalThis;try{return this||new Function("return this")()}catch(e){if("object"==typeof window)return window}}(),function(n){let{ampUrl:t,isCustomizePreview:r,isAmpDevMode:o,noampQueryVarName:s,noampQueryVarValue:i,disabledStorageKey:a,mobileUserAgents:c,regexRegex:u}=n;if("undefined"==typeof sessionStorage)return;const d=new RegExp(u);if(!c.some((e=>{const n=e.match(d);return!(!n||!new RegExp(n[1],n[2]).test(navigator.userAgent))||navigator.userAgent.includes(e)})))return;e.g.addEventListener("DOMContentLoaded",(()=>{const e=document.getElementById("amp-mobile-version-switcher");if(!e)return;e.hidden=!1;const n=e.querySelector("a[href]");n&&n.addEventListener("click",(()=>{sessionStorage.removeItem(a)}))}));const g=o&&["paired-browsing-non-amp","paired-browsing-amp"].includes(window.name);if(sessionStorage.getItem(a)||r||g)return;const m=new URL(location.href),h=new URL(t);h.hash=m.hash,m.searchParams.has(s)&&i===m.searchParams.get(s)?sessionStorage.setItem(a,"1"):h.href!==m.href&&(window.stop(),location.replace(h.href))}({"ampUrl":"https:\/\/wallstreetwindow.com\/2022\/06\/big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos\/amp\/","noampQueryVarName":"noamp","noampQueryVarValue":"mobile","disabledStorageKey":"amp_mobile_redirect_disabled","mobileUserAgents":["Mobile","Android","Silk\/","Kindle","BlackBerry","Opera Mini","Opera Mobi"],"regexRegex":"^\\/((?:.|\n)+)\\/([i]*)$","isCustomizePreview":false,"isAmpDevMode":false})}();</script> <meta name='robots' content='max-image-preview:large' /><link rel="icon" type="image/png" href="https://wallstreetwindow.com/wp-content/uploads/2019/10/newsim.jpg"><link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /><link rel="alternate" type="application/rss+xml" title="WallStreetWindow.com &raquo; Feed" href="https://wallstreetwindow.com/feed/" /><link rel="alternate" type="application/rss+xml" title="WallStreetWindow.com &raquo; Comments Feed" href="https://wallstreetwindow.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="WallStreetWindow.com &raquo; Big Tech Mounting Big-Money Fight to Defeat to Corporate Antitrust Bill &#8211; Andrea Germanos Comments Feed" href="https://wallstreetwindow.com/2022/06/big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/wallstreetwindow.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);</script> <noscript><link crossorigin="anonymous" rel='stylesheet'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto+Condensed%3A400%2C500%2C700&#038;display=swap&#038;ver=5.2' type='text/css' media='all' /></noscript><link crossorigin="anonymous" rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto+Condensed%3A400%2C500%2C700&#038;display=swap&#038;ver=5.2' type='text/css' media='print' onload="this.onload=null;this.media='all';" /> <script type='text/javascript' src='https://wallstreetwindow.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <script type='text/javascript' id='optimizepress-op-jquery-base-all-js-extra'>var OptimizePress = {"ajaxurl":"https:\/\/wallstreetwindow.com\/wp-admin\/admin-ajax.php","SN":"optimizepress","version":"2.5.25","script_debug":".min","localStorageEnabled":"","wp_admin_page":"","op_live_editor":"","op_page_builder":"","op_create_new_page":"","imgurl":"https:\/\/wallstreetwindow.com\/wp-content\/plugins\/optimizePressPlugin\/lib\/images\/","OP_URL":"https:\/\/wallstreetwindow.com\/wp-content\/plugins\/optimizePressPlugin\/","OP_JS":"https:\/\/wallstreetwindow.com\/wp-content\/plugins\/optimizePressPlugin\/lib\/js\/","OP_PAGE_BUILDER_URL":"","include_url":"https:\/\/wallstreetwindow.com\/wp-includes\/","op_autosave_interval":"300","op_autosave_enabled":"N","paths":{"url":"https:\/\/wallstreetwindow.com\/wp-content\/plugins\/optimizePressPlugin\/","img":"https:\/\/wallstreetwindow.com\/wp-content\/plugins\/optimizePressPlugin\/lib\/images\/","js":"https:\/\/wallstreetwindow.com\/wp-content\/plugins\/optimizePressPlugin\/lib\/js\/","css":"https:\/\/wallstreetwindow.com\/wp-content\/plugins\/optimizePressPlugin\/lib\/css\/"},"social":{"twitter":"optimizepress","facebook":"optimizepress","googleplus":"111273444733787349971"},"flowplayerHTML5":"https:\/\/wallstreetwindow.com\/wp-content\/plugins\/optimizePressPlugin\/lib\/modules\/blog\/video\/flowplayer\/flowplayer.swf","flowplayerKey":"","flowplayerLogo":"","mediaelementplayer":"https:\/\/wallstreetwindow.com\/wp-content\/plugins\/optimizePressPlugin\/lib\/modules\/blog\/video\/mediaelement\/","pb_unload_alert":"This page is asking you to confirm that you want to leave - data you have entered may not be saved.","pb_save_alert":"Please make sure you are happy with all of your options as some options will not be able to be changed for this page later.","search_default":"Search...","ems_providers":{"mailchimp":"MailChimp"},"optimizemember":{"enabled":false,"version":"0"},"OP_LEADS_URL":"https:\/\/my.optimizeleads.com\/","OP_LEADS_THEMES_URL":"https:\/\/my.optimizeleads.com\/build\/themes\/","google_recaptcha_site_key":""};</script>  <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-393039-1' id='google_gtagjs-js' async></script> <script type='text/javascript' id='google_gtagjs-js-after'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["wallstreetwindow.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-393039-1", {"anonymize_ip":true});</script> <link rel="https://api.w.org/" href="https://wallstreetwindow.com/wp-json/" /><link rel="alternate" type="application/json" href="https://wallstreetwindow.com/wp-json/wp/v2/posts/47391" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://wallstreetwindow.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://wallstreetwindow.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 6.0" /><link rel="canonical" href="https://wallstreetwindow.com/2022/06/big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos/" /><link rel='shortlink' href='https://wallstreetwindow.com/?p=47391' /><link rel="alternate" type="application/json+oembed" href="https://wallstreetwindow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwallstreetwindow.com%2F2022%2F06%2Fbig-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos%2F" /><link rel="alternate" type="text/xml+oembed" href="https://wallstreetwindow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwallstreetwindow.com%2F2022%2F06%2Fbig-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.75.0" /> <!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--> <script>window.tdwGlobal = {"adminUrl":"https:\/\/wallstreetwindow.com\/wp-admin\/","wpRestNonce":"16ece50c4f","wpRestUrl":"https:\/\/wallstreetwindow.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%postname%\/"};</script> <meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236"><meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com"> <!--[if (gte IE 6)&(lte IE 8)]> <script type="text/javascript" src="https://wallstreetwindow.com/wp-content/plugins/optimizePressPlugin/lib/js/selectivizr-1.0.2-min.js?ver=1.0.2"></script> <![endif]--> <!--[if lt IE 9]> <script src="https://wallstreetwindow.com/wp-content/plugins/optimizePressPlugin/lib/js//html5shiv.min.js"></script> <![endif]--><link rel="amphtml" href="https://wallstreetwindow.com/2022/06/big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos/amp/"> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script>  <script async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-4109913372673832" crossorigin="anonymous" type="text/javascript"></script> <link rel="alternate" type="text/html" media="only screen and (max-width: 640px)" href="https://wallstreetwindow.com/2022/06/big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos/amp/">  <script>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</script>  <script type="application/ld+json">{
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://wallstreetwindow.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://wallstreetwindow.com/category/us-and-the-world/us-politics/",
                    "name": "US Politics"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://wallstreetwindow.com/2022/06/big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos/",
                    "name": "Big Tech Mounting Big-Money Fight to Defeat to Corporate Antitrust Bill &#8211;..."                                
                }
            }    
        ]
    }</script> <link rel="icon" href="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2019/10/newsim.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2019/10/newsim.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2019/10/newsim.jpg?fit=180%2C180&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2019/10/newsim.jpg?fit=250%2C250&#038;ssl=1" />  <script type='text/javascript'>var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-393039-1']);
_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();</script> <link rel="canonical" href="https://wallstreetwindow.com/?p=47391" /><meta property="og:url" content="https://wallstreetwindow.com/?p=47391" /></head><body data-rsssl=1 class="post-template-default single single-post postid-47391 single-format-standard op-plugin big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos global-block-template-1 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up  td-hide-scroll-up-on-mob"  style="display:none;"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/wallstreetwindow/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="http://feeds.feedburner.com/Wallstreetwindow-all" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/tradermike_1999" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/channel/UCPAxB5TPQ_5PVXWYIgAx4Mw" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div><div class="td-mobile-close"> <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-menu-login-section"><div class="td-guest-wrap"><div class="td-menu-login"><a id="login-link-mob">Sign in</a></div></div></div><div class="td-mobile-content"><div class="menu-navbar-container"><ul id="menu-navbar" class="td-mobile-main-menu"><li id="menu-item-2828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first menu-item-2828"><a href="https://wallstreetwindow.com/about-us/">About US</a></li><li id="menu-item-2602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2602"><a href="https://wallstreetwindow.com/category/stock-market-investing/">Stock Investing<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-2603" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2603"><a href="https://wallstreetwindow.com/category/stock-market-investing/stock-market-news/">Stock Market News</a></li><li id="menu-item-2604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2604"><a href="https://wallstreetwindow.com/category/stock-market-investing/stock-picks/">Stock Picks</a></li><li id="menu-item-2605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2605"><a href="https://wallstreetwindow.com/category/stock-market-investing/stock-trading/">Stock Trading Strategies</a></li><li id="menu-item-2606" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2606"><a href="https://wallstreetwindow.com/category/stock-market-investing/technical-analysis/">Technical Analysis</a></li></ul></li><li id="menu-item-2836" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2836"><a href="https://wallstreetwindow.com/category/commodities/">Commodities<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-2840" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2840"><a href="https://wallstreetwindow.com/category/commodities/precious-metals/">Precious Metals Prices</a></li><li id="menu-item-2837" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2837"><a href="https://wallstreetwindow.com/category/commodities/agriculture/">Agriculture and Soft Commodities</a></li><li id="menu-item-2838" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2838"><a href="https://wallstreetwindow.com/category/commodities/energy/">Energy</a></li><li id="menu-item-2839" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2839"><a href="https://wallstreetwindow.com/category/commodities/gold-stocks/">Gold Stocks</a></li></ul></li><li id="menu-item-2841" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2841"><a href="https://wallstreetwindow.com/category/business-economy/">Business and Economy<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-2844" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2844"><a href="https://wallstreetwindow.com/category/business-economy/federal-reserve/">Federal Reserve</a></li><li id="menu-item-2842" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2842"><a href="https://wallstreetwindow.com/category/business-economy/economic-news/">Economic News</a></li><li id="menu-item-2843" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2843"><a href="https://wallstreetwindow.com/category/business-economy/economic-trends/">Economic Trends</a></li><li id="menu-item-2845" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2845"><a href="https://wallstreetwindow.com/category/business-economy/marketing/">Marketing</a></li></ul></li><li id="menu-item-2821" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-2821"><a href="https://wallstreetwindow.com/category/us-and-the-world/">America and the World<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-2825" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2825"><a href="https://wallstreetwindow.com/category/us-and-the-world/us-politics/">US Politics</a></li><li id="menu-item-2824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2824"><a href="https://wallstreetwindow.com/category/us-and-the-world/american-empire/">The War State</a></li><li id="menu-item-2823" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2823"><a href="https://wallstreetwindow.com/category/us-and-the-world/geopolitics/">Geopolitics</a></li><li id="menu-item-2826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2826"><a href="https://wallstreetwindow.com/category/us-and-the-world/the-20th-century/">The Past American Century</a></li><li id="menu-item-2822" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2822"><a href="https://wallstreetwindow.com/category/us-and-the-world/high-and-low-culture/">Culture and Society</a></li></ul></li><li id="menu-item-39861" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39861"><a href="https://wallstreetwindow.com/category/state/">State News<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-39665" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39665"><a href="https://wallstreetwindow.com/category/state/north-carolina-news/">North Carolina News<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-42042" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42042"><a href="https://wallstreetwindow.com/category/state/north-carolina-news/greensboro-and-guilford-county-news/">Greensboro and Guilford County News</a></li><li id="menu-item-43465" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43465"><a href="https://wallstreetwindow.com/category/state/north-carolina-news/high-point/">High Point</a></li><li id="menu-item-39666" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39666"><a href="https://wallstreetwindow.com/category/state/north-carolina-news/eden-riedsville-rockingham-nc-news/">Rockingham County, NC News</a></li></ul></li><li id="menu-item-39667" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-39667"><a href="https://wallstreetwindow.com/category/state/virginia-news/">Virginia News<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-39668" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39668"><a href="https://wallstreetwindow.com/category/state/virginia-news/danville-news/">Danville-News</a></li><li id="menu-item-39888" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39888"><a href="https://wallstreetwindow.com/category/state/virginia-news/martinsville-news/">Martinsville and Henry County News</a></li><li id="menu-item-42043" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42043"><a href="https://wallstreetwindow.com/category/state/virginia-news/pittsylvania-county/">Pittsylvania County</a></li><li id="menu-item-43466" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43466"><a href="https://wallstreetwindow.com/category/state/virginia-news/south-boston-halifax-county-news/">South Boston and Halifax County News</a></li></ul></li></ul></li><li id="menu-item-2830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2830"><a href="https://www.youtube.com/user/Tradermike2005">Youtube Channel</a></li><li id="menu-item-40377" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-40377"><a href="https://wallstreetwindow.com/two-fold-formula-stock-pick">Subscribe Daily News Digest<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-42055" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42055"><a href="https://wallstreetwindow.com/beintheknow-nc-piedmontregion">Subscribe (Greensboro, Winston-Salem, Piedmont NC Region)</a></li><li id="menu-item-42054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42054"><a href="https://wallstreetwindow.com/beintheknow-nc-rockinghamcounty">Subscribe (Rockingham County, NC)</a></li><li id="menu-item-40375" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40375"><a href="https://wallstreetwindow.com/beintheknow">Subscribe (Danville, Martinsville, Halifax VA News)</a></li></ul></li><li id="menu-item-42258" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-42258"><a href="https://wallstreetwindow.com/republishing-guidelines/">Republishing Guidelines</a></li><li id="menu-item-2852" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2852"><a href="https://wallstreetwindow.com/contactus">Contact Us</a></li></ul></div></div></div><div id="login-form-mobile" class="td-register-section"><div id="td-login-mob" class="td-login-animation td-login-hide-mob"><div class="td-login-close"> <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Sign in</div><div class="td-mobile-close"> <a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a></div></div><form class="td-login-form-wrap" action="#" method="post"><div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email-mob" value="" required><label for="login_email-mob">your username</label></div><div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass-mob" value="" required><label for="login_pass-mob">your password</label></div> <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN"><div class="td-login-info-text"><a href="#" id="forgot-pass-link-mob">Forgot your password?</a></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://wallstreetwindow.com/privacy.htm">Privacy Policy</a></div></form></div><div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob"><div class="td-forgot-pass-close"> <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-read-down"></i></a><div class="td-login-title">Password recovery</div></div><div class="td-login-form-wrap"><div class="td-login-panel-title">Recover your password</div><div class="td_display_err"></div><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label for="forgot_email-mob">your email</label></div> <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass"></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://wallstreetwindow.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob"></div></div></div><div id="td-outer-wrap"><div class="td-outer-container"><div class="td-header-wrap td-header-container td-header-style-7"><div class="td-header-row td-header-top-menu"><div class="td-top-bar-container top-bar-style-1"><div class="td-header-sp-top-menu"><div class="td_data_time"><div > Thursday, June 9, 2022</div></div><ul class="top-header-menu td_ul_login"><li class="menu-item"><a class="td-login-modal-js menu-item" href="#login-form" data-effect="mpf-td-login-effect">Sign in / Join</a></li></ul></div><div class="td-header-sp-top-widget"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/wallstreetwindow/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="http://feeds.feedburner.com/Wallstreetwindow-all" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/tradermike_1999" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/channel/UCPAxB5TPQ_5PVXWYIgAx4Mw" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div></div><div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim"><div class="td-login-wrap"> <a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a><div id="td-login-div" class="td-login-form-div td-display-block"><div class="td-login-panel-title">Sign in</div><div class="td-login-panel-descr">Welcome! Log into your account</div><div class="td_display_err"></div><form id="loginForm" action="#" method="post"><div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div><div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div> <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login"></form><div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div><div class="td-login-info-text"><a class="privacy-policy-link" href="https://wallstreetwindow.com/privacy.htm">Privacy Policy</a></div></div><div id="td-forgot-pass-div" class="td-login-form-div td-display-none"><div class="td-login-panel-title">Password recovery</div><div class="td-login-panel-descr">Recover your password</div><div class="td_display_err"></div><form id="forgotpassForm" action="#" method="post"><div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div> <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password"></form><div class="td-login-info-text">A password will be e-mailed to you.</div></div></div></div></div><div class="td-header-row td-header-header"><div class="td-header-sp-logo"> <span class="td-logo-text-container"> <a class="td-logo-wrap" href="https://wallstreetwindow.com/"> <span class="td-logo-text">WallStreetWindow</span> <span class="td-tagline-text">Be In The Know</span> </a> </span></div></div><div class="td-header-menu-wrap"><div class="td-header-row td-header-border td-header-main-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#" aria-label="mobile-toggle"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header"></div><div class="menu-navbar-container"><ul id="menu-navbar-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-2828"><a href="https://wallstreetwindow.com/about-us/">About US</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-2602"><a href="https://wallstreetwindow.com/category/stock-market-investing/">Stock Investing</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2603"><a href="https://wallstreetwindow.com/category/stock-market-investing/stock-market-news/">Stock Market News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2604"><a href="https://wallstreetwindow.com/category/stock-market-investing/stock-picks/">Stock Picks</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2605"><a href="https://wallstreetwindow.com/category/stock-market-investing/stock-trading/">Stock Trading Strategies</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2606"><a href="https://wallstreetwindow.com/category/stock-market-investing/technical-analysis/">Technical Analysis</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-2836"><a href="https://wallstreetwindow.com/category/commodities/">Commodities</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2840"><a href="https://wallstreetwindow.com/category/commodities/precious-metals/">Precious Metals Prices</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2837"><a href="https://wallstreetwindow.com/category/commodities/agriculture/">Agriculture and Soft Commodities</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2838"><a href="https://wallstreetwindow.com/category/commodities/energy/">Energy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2839"><a href="https://wallstreetwindow.com/category/commodities/gold-stocks/">Gold Stocks</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-2841"><a href="https://wallstreetwindow.com/category/business-economy/">Business and Economy</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2844"><a href="https://wallstreetwindow.com/category/business-economy/federal-reserve/">Federal Reserve</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2842"><a href="https://wallstreetwindow.com/category/business-economy/economic-news/">Economic News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2843"><a href="https://wallstreetwindow.com/category/business-economy/economic-trends/">Economic Trends</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2845"><a href="https://wallstreetwindow.com/category/business-economy/marketing/">Marketing</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children td-menu-item td-normal-menu menu-item-2821"><a href="https://wallstreetwindow.com/category/us-and-the-world/">America and the World</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-2825"><a href="https://wallstreetwindow.com/category/us-and-the-world/us-politics/">US Politics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2824"><a href="https://wallstreetwindow.com/category/us-and-the-world/american-empire/">The War State</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2823"><a href="https://wallstreetwindow.com/category/us-and-the-world/geopolitics/">Geopolitics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2826"><a href="https://wallstreetwindow.com/category/us-and-the-world/the-20th-century/">The Past American Century</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2822"><a href="https://wallstreetwindow.com/category/us-and-the-world/high-and-low-culture/">Culture and Society</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-39861"><a href="https://wallstreetwindow.com/category/state/">State News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-39665"><a href="https://wallstreetwindow.com/category/state/north-carolina-news/">North Carolina News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-42042"><a href="https://wallstreetwindow.com/category/state/north-carolina-news/greensboro-and-guilford-county-news/">Greensboro and Guilford County News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-43465"><a href="https://wallstreetwindow.com/category/state/north-carolina-news/high-point/">High Point</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-39666"><a href="https://wallstreetwindow.com/category/state/north-carolina-news/eden-riedsville-rockingham-nc-news/">Rockingham County, NC News</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-39667"><a href="https://wallstreetwindow.com/category/state/virginia-news/">Virginia News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-39668"><a href="https://wallstreetwindow.com/category/state/virginia-news/danville-news/">Danville-News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-39888"><a href="https://wallstreetwindow.com/category/state/virginia-news/martinsville-news/">Martinsville and Henry County News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-42043"><a href="https://wallstreetwindow.com/category/state/virginia-news/pittsylvania-county/">Pittsylvania County</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-43466"><a href="https://wallstreetwindow.com/category/state/virginia-news/south-boston-halifax-county-news/">South Boston and Halifax County News</a></li></ul></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-2830"><a href="https://www.youtube.com/user/Tradermike2005">Youtube Channel</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-40377"><a href="https://wallstreetwindow.com/two-fold-formula-stock-pick">Subscribe Daily News Digest</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-42055"><a href="https://wallstreetwindow.com/beintheknow-nc-piedmontregion">Subscribe (Greensboro, Winston-Salem, Piedmont NC Region)</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-42054"><a href="https://wallstreetwindow.com/beintheknow-nc-rockinghamcounty">Subscribe (Rockingham County, NC)</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-40375"><a href="https://wallstreetwindow.com/beintheknow">Subscribe (Danville, Martinsville, Halifax VA News)</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-42258"><a href="https://wallstreetwindow.com/republishing-guidelines/">Republishing Guidelines</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2852"><a href="https://wallstreetwindow.com/contactus">Contact Us</a></li></ul></div></div><div class="td-search-wrapper"><div id="td-top-search"><div class="header-search-wrap"><div class="dropdown header-search"> <a id="td-header-search-button" href="#" role="button" aria-label="search icon" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" role="button" aria-label="search icon" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div></div></div></div><div class="header-search-wrap"><div class="dropdown header-search"><div class="td-drop-down-search"><form method="get" class="td-search-form" action="https://wallstreetwindow.com/"><div role="search" class="td-head-form-search-wrap"> <input class="needsclick" id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div><div class="td-header-container"><div class="td-header-row"><div class="td-header-sp-rec"><div class="td-header-ad-wrap "></div></div></div></div></div><div class="td-container td-post-template-default"><div class="td-container-border"><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-47391" class="post-47391 post type-post status-publish format-standard has-post-thumbnail hentry category-us-politics" itemscope itemtype="https://schema.org/Article"47><div class="td-post-header td-pb-padding-side"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://wallstreetwindow.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in US Politics" class="entry-crumb" href="https://wallstreetwindow.com/category/us-and-the-world/us-politics/">US Politics</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Big Tech Mounting Big-Money Fight to Defeat to Corporate Antitrust Bill &#8211;...</span></div><ul class="td-category"><li class="entry-category"><a  href="https://wallstreetwindow.com/category/us-and-the-world/">America and the World</a></li><li class="entry-category"><a  href="https://wallstreetwindow.com/category/us-and-the-world/us-politics/">US Politics</a></li></ul><header><h1 class="entry-title">Big Tech Mounting Big-Money Fight to Defeat to Corporate Antitrust Bill &#8211; Andrea Germanos</h1><div class="meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://wallstreetwindow.com/author/wswstaff/">wsw staff</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-09T01:41:00-04:00" >June 9, 2022</time></span></div></header></div><div class="td-post-content td-pb-padding-side"><div class="td-post-featured-image"><a href="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2021/02/624px-Jeff_Bezos_iconic_laugh.jpg?fit=624%2C720&ssl=1" data-caption=""><img width="624" height="720" class="entry-thumb td-modal-image" src="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2021/02/624px-Jeff_Bezos_iconic_laugh.jpg?resize=624%2C720&ssl=1" srcset="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2021/02/624px-Jeff_Bezos_iconic_laugh.jpg?w=624&ssl=1 624w, https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2021/02/624px-Jeff_Bezos_iconic_laugh.jpg?resize=260%2C300&ssl=1 260w" sizes="(max-width: 624px) 100vw, 624px" alt="" title="624px-Jeff_Bezos'_iconic_laugh"/></a></div><p><strong>Amazon and tech giants</strong> are mounting a big-money push to tank bipartisan antitrust legislation its proponents <a href="https://www.economicliberties.us/press-release/bipartisan-coalition-of-senators-agree-big-tech-is-too-powerful/#">say</a> rightly takes on concentrated corporate power undermining small businesses and democracy.</p><p>Introduced in October by lead co-sponsors Sens. Amy Klobuchar (D-Minn.) and Chuck Grassley (R-Iowa.), the American Innovation and Choice Online Act (<a href="https://www.congress.gov/bill/117th-congress/senate-bill/2992/text">S.2992</a>) is coming up against negative media and spending blitzes ahead of a possible vote later this month.</p><p><em>Bloomberg</em> <a href="https://www.bloomberg.com/news/articles/2022-06-07/lobbying-intensifies-over-senate-undecideds-on-antitrust-bill">reported</a> Monday that Senate Majority Leader Chuck Schumer (D-N.Y.) has promised a vote on the legislation this month, noting the narrow window ahead of the August recess.</p><p>The bill would, among other provisions, prevent major platforms like Amazon and Google from giving preferential treatment to their own products.</p><p>According to a report <a href="https://www.americanprogress.org/article/evaluating-2-tech-antitrust-bills-to-restore-competition-online/">released</a> last week by the Center for American Progress, the measure would &#8220;protect American consumers, small businesses, and innovation online.&#8221;</p><p>Industry lobby groups and major tech firms, however, are &#8220;going all out&#8221; against the bill, <em>Axios</em> <a href="https://www.axios.com/2022/06/06/antitrust-bills-progress-tech-lobbying-splurge">reported</a> Monday.</p><p>Dharmesh Mehta, Amazon&#8217;s vice president of worldwide selling partner services, for example, &#8220;recently tried lobbying third-party sellers on an online forum that they use to communicate with one another about hot topics&#8221; to encourage them to oppose the measure,<a href="https://www.cnbc.com/2022/06/06/amazon-executive-encourages-sellers-to-oppose-antitrust-bill.html"> according to</a> <em>CNBC</em>. &#8220;I want to ensure that you are aware of this legislation and what you can do to try and stop it from harming you,&#8221; he wrote in part, and directed sellers to a contact-your-senator form. <em>CNBC</em> added:</p><blockquote class="wp-block-quote"><p>Hundreds of sellers replied to Mehta&#8217;s post, including many who seemed unconvinced by Amazon&#8217;s point of view and promised to support the legislation. Third-party sellers, who account for more than half of Amazon&#8217;s retail volume, have in recent years expressed frustration over the <a href="https://www.cnbc.com/2022/04/13/amazon-slaps-us-sellers-with-5percent-fuel-and-inflation-surcharge.html">costs</a> they pay to stay in good standing, the amount Amazon charges them for ads, and Amazon&#8217;s inability to rid the marketplace of <a href="https://www.cnbc.com/2022/02/11/former-amazon-employee-sentenced-to-10-months-in-bribery-scheme.html">scams</a> and bad actors.</p></blockquote><p>U.S. Chamber of Commerce executive vice president Neil Bradley also came out swinging against the bill, writing in a Monday blog post that it would afford &#8220;unprecedented authority to bureaucrats at the FTC and DOJ allowing them to micro-manage the American economy and pick winners and losers in the marketplace.&#8221; And in a letter to senators last week, the chamber called it &#8220;misguided&#8221; and urged lawmakers to vote against it.</p><p>To help achieve that aim, as a <em>Washington Post</em> analysis <a href="https://www.washingtonpost.com/politics/2022/06/06/multi-million-dollar-campaign-is-pushing-dems-ditch-antitrust-reform/">published</a> Monday highlighted, &#8220;tech trade associations and groups with ties to industry giants are&#8230; launching a major advertising blitz that&#8217;s increasingly targeting swing-state Democrats.&#8221;</p><p>The <em>Post</em> reported:</p><blockquote class="wp-block-quote"><p>&#8220;CCIA—a trade group that counts Amazon, Apple, Facebook, and Google as members—took out over $8 million in TV ads earlier this year primarily targeting swing states like Arizona, Georgia, Nevada, and Wisconsin, <a href="https://www.levernews.com/dont-break-our-prime-2/">according to the independent news site the <em>Lever</em></a>. CCIA also took out over $2 million in ads in New Hampshire, <a href="https://nhjournal.com/dont-break-what-works-campaign-comes-to-nh/">according to the <em>New Hampshire Journal</em></a>. (Amazon founder Jeff Bezos owns <em>The Washington Post</em>.)</p></blockquote><p>In recent months, another group called New Democracy has &#8220;taken out at least $167,000 in Facebook ads and over $218,000 in Google ads that largely call on a narrow set of swing-state Democrats to reject the bill,&#8221; the <em>Post</em> added. &#8220;The ads have been shown at least 13 million times, according to a review by The Technology 202 of the companies’ digital advertising libraries.&#8221;</p><p><em>Bloomberg</em> also noted that &#8220;Apple, Amazon, Google, and [Facebook parent company] Meta spent $16.7 million lobbying in the first three months of 2022, with all four identifying the antitrust bills as their top priority, according to lobbying disclosures filed with Congress,&#8221; referencing the Senate and House versions. And Apple, <em>Axios</em> <a href="https://www.axios.com/2022/06/06/antitrust-bills-progress-tech-lobbying-splurge">reported</a> Monday, &#8220;spent more on lobbying last quarter ($2.5 million) than in any previous quarter.&#8221;</p><p>The money may have been well spent.</p><p>The legislation &#8220;passed the Senate Judiciary Committee with support from both parties earlier this year,&#8221; <em>Politico</em> <a href="https://www.politico.com/news/2022/05/26/vulnerable-senate-democrats-back-off-big-tech-bill-00035307">reported</a> last month. However, &#8220;in the days since Senate Majority Leader Chuck Schumer told Klobuchar he would hold a floor vote as early as [June], several Democratic senators have privately expressed deep reservations about voting for the legislation, particularly with a midterm election looming, in their conversations with Schumer and other Democratic offices.&#8221;</p><p>Fight for the Future, a digital rights group backing the legislation, said in an email to supporters Tuesday that &#8220;a small faction of Senate Democrats may be betraying you for Big Tech.&#8221;</p><p>&#8220;There is no question that these lawmakers, including Maggie Hassan (N.H.), Michael Bennet (Colo.), Brian Schatz (Hawaii), Dianne Feinstein (Calif.), and Alejandro Padilla (Calif.), are being swayed by Big Tech lobbyists,&#8221; the group wrote.</p><p>&#8220;But siding with Big Tech at the expense of passing legislation that would rein in monopolistic companies that abuse their gatekeeper status to undermine human rights, distort democracy, abuse our personal data, and stifle competition,&#8221; said Fight for the Future, &#8220;is just wrong.&#8221;</p><p>Stacy Mitchell, co-director at the Institute for Local Self-Reliance, <a href="https://twitter.com/stacyfmitchell/status/1532344583899820033">called</a> Klobuchar&#8217;s bill &#8220;simple, bipartisan, wildly popular with voters, and a good first step toward reining in Big Tech.&#8221;</p><p>In a lengthy Twitter thread last week debunking Amazon&#8217;s claim that the legislation would kill its Prime service, Mitchell wrote that the measure would stop the online retail giant and other Big Tech firms from &#8220;self-preferencing and market manipulation.&#8221;</p><p>Its passage, she added, could bring about &#8220;the end of some of the most nakedly monopolistic tactics used by Big Tech.&#8221;</p><p>THIS ARTICLE ORIGINALLY <a href="https://www.commondreams.org/news/2022/06/07/big-tech-mounting-big-money-fight-defeat-corporate-antitrust-bill">POSTED HERE</a>.</p></div><footer><div class="td-post-source-tags td-pb-padding-side"></div><div class="td-post-sharing-bottom td-pb-padding-side"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://wallstreetwindow.com/2022/06/big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwallstreetwindow.com%2F2022%2F06%2Fbig-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos%2F" title="Facebook" ><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Big+Tech+Mounting+Big-Money+Fight+to+Defeat+to+Corporate+Antitrust+Bill+%E2%80%93+Andrea+Germanos&url=https%3A%2F%2Fwallstreetwindow.com%2F2022%2F06%2Fbig-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos%2F&via=WallStreetWindow.com" title="Twitter" ><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://wallstreetwindow.com/2022/06/big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos/&amp;media=https://wallstreetwindow.com/wp-content/uploads/2021/02/624px-Jeff_Bezos_iconic_laugh.jpg&description=Big+Tech+Mounting+Big-Money+Fight+to+Defeat+to+Corporate+Antitrust+Bill+%E2%80%93+Andrea+Germanos" title="Pinterest" ><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Big+Tech+Mounting+Big-Money+Fight+to+Defeat+to+Corporate+Antitrust+Bill+%E2%80%93+Andrea+Germanos %0A%0A https://wallstreetwindow.com/2022/06/big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos/" title="WhatsApp" ><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-print" href="#" title="Print" ><div class="td-social-but-icon"><i class="td-icon-print"></i></div><div class="td-social-but-text">Print</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://wallstreetwindow.com/2022/06/trump-on-trial-what-to-know-and-how-to-watch-the-jan-6-hearings-jessica-corbett/">&#8216;Trump on Trial&#8217;: What to Know and How to Watch the Jan. 6 Hearings &#8211; Jessica Corbett</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://wallstreetwindow.com/2022/06/how-a-public-hearing-is-different-from-an-investigation-and-what-that-means-for-the-jan-6-committee-claire-leavitt/">How a public hearing is different from an investigation – and what that means for the Jan. 6 committee &#8211; Claire Leavitt</a></div></div></div><div class="author-box-wrap"><a href="https://wallstreetwindow.com/author/wswstaff/" aria-label="author-photo"><img alt src="https://secure.gravatar.com/avatar/d2882345adbea4d4b53138cd882691e3?s=96&#038;d=mm&#038;r=g" class="avatar avatar-96 photo jetpack-lazy-image" height="96" width="96" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/d2882345adbea4d4b53138cd882691e3?s=192&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/d2882345adbea4d4b53138cd882691e3?s=96&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/d2882345adbea4d4b53138cd882691e3?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d2882345adbea4d4b53138cd882691e3?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy'/></noscript></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://wallstreetwindow.com/author/wswstaff/">wsw staff</a></span></div><div class="td-author-description">I am a staff writer and editor for WallStreetWindow.com.  I actually am a composite account that is used by several people who work for the website.  We are all united in giving good content for the website visitors.</div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="wsw staff"><meta itemprop="url" content="https://wallstreetwindow.com/author/wswstaff/"></span><meta itemprop="datePublished" content="2022-06-09T01:41:00-04:00"><meta itemprop="dateModified" content="2022-06-07T15:42:53-04:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://wallstreetwindow.com/2022/06/big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://wallstreetwindow.com/2022/06/big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos/"></span><meta itemprop="name" content="WallStreetWindow.com"></span><meta itemprop="headline " content="Big Tech Mounting Big-Money Fight to Defeat to Corporate Antitrust Bill - Andrea Germanos"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2021/02/624px-Jeff_Bezos_iconic_laugh.jpg?fit=624%2C720&ssl=1"><meta itemprop="width" content="624"><meta itemprop="height" content="720"></span></footer></article>  <script>var block_tdi_3 = new tdBlock();
block_tdi_3.id = "tdi_3";
block_tdi_3.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_3","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":47391,"live_filter_cur_post_author":"3","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_3","tdc_css_class_style":"tdi_3_rand_style"}';
block_tdi_3.td_column_number = "3";
block_tdi_3.block_type = "td_block_related_posts";
block_tdi_3.post_count = "3";
block_tdi_3.found_posts = "2046";
block_tdi_3.header_color = "";
block_tdi_3.ajax_pagination_infinite_stop = "";
block_tdi_3.max_num_pages = "682";
tdBlocksArray.push(block_tdi_3);</script><div class="td_block_wrap td_block_related_posts tdi_3 td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_3" ><h4 class="td-related-title"><a id="tdi_4" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_3" href="#">RELATED ARTICLES</a><a id="tdi_5" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_3" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_3 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://wallstreetwindow.com/2022/06/how-a-public-hearing-is-different-from-an-investigation-and-what-that-means-for-the-jan-6-committee-claire-leavitt/" rel="bookmark" class="td-image-wrap " title="How a public hearing is different from an investigation – and what that means for the Jan. 6 committee &#8211; Claire Leavitt" ><img class="entry-thumb" src="" alt="" title="How a public hearing is different from an investigation – and what that means for the Jan. 6 committee &#8211; Claire Leavitt" data-type="image_tag" data-img-url="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2018/01/De-Tocqueville-Democracy-.jpg?resize=238%2C178&ssl=1"  width="238" height="178" /></a></div> <a href="https://wallstreetwindow.com/category/us-and-the-world/us-politics/" class="td-post-category">US Politics</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://wallstreetwindow.com/2022/06/how-a-public-hearing-is-different-from-an-investigation-and-what-that-means-for-the-jan-6-committee-claire-leavitt/" rel="bookmark" title="How a public hearing is different from an investigation – and what that means for the Jan. 6 committee &#8211; Claire Leavitt">How a public hearing is different from an investigation – and what that means for the Jan. 6 committee &#8211; Claire Leavitt</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://wallstreetwindow.com/2022/06/trump-on-trial-what-to-know-and-how-to-watch-the-jan-6-hearings-jessica-corbett/" rel="bookmark" class="td-image-wrap " title="&#8216;Trump on Trial&#8217;: What to Know and How to Watch the Jan. 6 Hearings &#8211; Jessica Corbett" ><img class="entry-thumb" src="" alt="" title="&#8216;Trump on Trial&#8217;: What to Know and How to Watch the Jan. 6 Hearings &#8211; Jessica Corbett" data-type="image_tag" data-img-url="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2020/07/Bonus_army_on_Capitol_lawn_cph.3a00515.jpg?resize=238%2C178&ssl=1"  width="238" height="178" /></a></div> <a href="https://wallstreetwindow.com/category/us-and-the-world/us-politics/" class="td-post-category">US Politics</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://wallstreetwindow.com/2022/06/trump-on-trial-what-to-know-and-how-to-watch-the-jan-6-hearings-jessica-corbett/" rel="bookmark" title="&#8216;Trump on Trial&#8217;: What to Know and How to Watch the Jan. 6 Hearings &#8211; Jessica Corbett">&#8216;Trump on Trial&#8217;: What to Know and How to Watch the Jan. 6 Hearings &#8211; Jessica Corbett</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://wallstreetwindow.com/2022/06/scorpions-dance-the-president-the-spymaster-and-watergate-w-jefferson-morley-source-parallax-views/" rel="bookmark" class="td-image-wrap " title="Scorpion’s Dance: The President, the Spymaster, and Watergate w/ Jefferson Morley &#8211; Source &#8211; Parallax Views" ><img class="entry-thumb" src="" alt="" title="Scorpion’s Dance: The President, the Spymaster, and Watergate w/ Jefferson Morley &#8211; Source &#8211; Parallax Views" data-type="image_tag" data-img-url="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2022/06/scorpionsdance.webp?resize=238%2C178&ssl=1"  width="238" height="178" /></a></div> <a href="https://wallstreetwindow.com/category/us-and-the-world/the-20th-century/jfk-assassination-history/" class="td-post-category">JFK Assassination History</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://wallstreetwindow.com/2022/06/scorpions-dance-the-president-the-spymaster-and-watergate-w-jefferson-morley-source-parallax-views/" rel="bookmark" title="Scorpion’s Dance: The President, the Spymaster, and Watergate w/ Jefferson Morley &#8211; Source &#8211; Parallax Views">Scorpion’s Dance: The President, the Spymaster, and Watergate w/ Jefferson Morley &#8211; Source &#8211; Parallax Views</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_3" data-td_block_id="tdi_3"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_3" data-td_block_id="tdi_3"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div><div class="comments" id="comments"></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><aside class="td_block_template_1 widget widget_block"><BR><center><a href="https://www.amazon.com/Danville-Virginia-Coming-Modern-South-ebook/dp/B007VCZLWW/"><img src="https://www.wallstreetwindow.com/images/2021/danvillebook1.jpg"></a></center> <BR><center><a href="https://kdp.amazon.com/amazon-dp-action/us/dualbookshelf.marketplacelink/B007ZHVBLS" target="_blank" rel="noopener"><img loading="lazy" src="https://wallstreetwindow.com/images/bookcover.jpg" width="160" height="241" border="0" /></a><img loading="lazy" style="border: none !important; margin: 0px !important;" src="https://www.assoc-amazon.com/e/ir?t=wallstreetwin-20&amp;l=as2&amp;o=1&amp;a=1453666710" alt="" width="1" height="1" border="0" /> <BR><center><a href="http://amzn.to/1JoaagS"><img src="https://i0.wp.com/wallstreetwindow.com/images/warstatejpeg.jpg?resize=160%2C241"></a></center><br><center><a href="https://www.amazon.com/Why-Vietnam-War-Southeast-1945-1961/dp/1734139358/"><img src="https://wallstreetwindow.com/images/2021/whyvietnamwar.jpg?resize=160%2C241"></a></center><br></aside><aside class="td_block_template_1 widget widget_block"><script type="text/javascript">adroll_adv_id = "XHMI3YCS3NAZNH5JHR6OEP";
    adroll_pix_id = "LBC34LBVCVETLHD5LZUO7U";
    adroll_version = "2.0";

    (function(w, d, e, o, a) {
        w.__adroll_loaded = true;
        w.adroll = w.adroll || [];
        w.adroll.f = [ 'setProperties', 'identify', 'track' ];
        var roundtripUrl = "https://s.adroll.com/j/" + adroll_adv_id
                + "/roundtrip.js";
        for (a = 0; a < w.adroll.f.length; a++) {
            w.adroll[w.adroll.f[a]] = w.adroll[w.adroll.f[a]] || (function(n) {
                return function() {
                    w.adroll.push([ n, arguments ])
                }
            })(w.adroll.f[a])
        }

        e = d.createElement('script');
        o = d.getElementsByTagName('script')[0];
        e.async = 1;
        e.src = roundtripUrl;
        o.parentNode.insertBefore(e, o);
    })(window, document);
    adroll.track("pageView");</script></aside></div></div></div></div></div><div class="td-footer-container td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span4"><div class="td-footer-info td-pb-padding-side"><div class="footer-logo-wrap"><a href="https://wallstreetwindow.com/"><img src="" alt="" title="" /></a></div><div class="footer-text-wrap">This is WallStreetWindow.   This is your portal of news from your front porch to the whole world.<div class="footer-email-wrap">Contact us: <a href="mailto:support@wallstreetwindow.com">support@wallstreetwindow.com</a></div></div><div class="footer-social-wrap td-social-style2"> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.facebook.com/wallstreetwindow/" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="http://feeds.feedburner.com/Wallstreetwindow-all" title="RSS"> <i class="td-icon-font td-icon-rss"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://twitter.com/tradermike_1999" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" href="https://www.youtube.com/channel/UCPAxB5TPQ_5PVXWYIgAx4Mw" title="Youtube"> <i class="td-icon-font td-icon-youtube"></i> </a> </span></div></div></div><div class="td-pb-span4"><div class="td_block_wrap td_block_7 tdi_7 td_block_template_1"  data-td-block-uid="tdi_7" ><script>var block_tdi_7 = new tdBlock();
block_tdi_7.id = "tdi_7";
block_tdi_7.atts = '{"custom_title":"EVEN MORE NEWS","border_top":"no_border_top","limit":3,"block_type":"td_block_7","separator":"","custom_url":"","title_tag":"","block_template_id":"","color_preset":"","m6_tl":"","m6_title_tag":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","offset":"","show_modified_date":"","video_popup":"","video_rec":"","video_rec_title":"","show_vid_t":"block","el_class":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","class":"tdi_7","tdc_css_class":"tdi_7","tdc_css_class_style":"tdi_7_rand_style"}';
block_tdi_7.td_column_number = "1";
block_tdi_7.block_type = "td_block_7";
block_tdi_7.post_count = "3";
block_tdi_7.found_posts = "9364";
block_tdi_7.header_color = "";
block_tdi_7.ajax_pagination_infinite_stop = "";
block_tdi_7.max_num_pages = "3122";
tdBlocksArray.push(block_tdi_7);</script><h4 class="block-title"><span class="td-pulldown-size">EVEN MORE NEWS</span></h4><div id=tdi_7 class="td_block_inner"><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack "><div class="td-module-thumb"><a href="https://wallstreetwindow.com/2022/06/stock-market-chaos-big-moves-happening-just-around-the-corner-chris-vermeulen/" rel="bookmark" class="td-image-wrap " title="Stock Market Chaos &#038; Big Moves Happening Just Around The Corner &#8211; Chris Vermeulen" ><img class="entry-thumb" src="" alt="" title="Stock Market Chaos &#038; Big Moves Happening Just Around The Corner &#8211; Chris Vermeulen" data-type="image_tag" data-img-url="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2018/03/stockglobe_1.jpg?resize=100%2C75&ssl=1"  width="100" height="75" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://wallstreetwindow.com/2022/06/stock-market-chaos-big-moves-happening-just-around-the-corner-chris-vermeulen/" rel="bookmark" title="Stock Market Chaos &#038; Big Moves Happening Just Around The Corner &#8211; Chris Vermeulen">Stock Market Chaos &#038; Big Moves Happening Just Around The Corner...</a></h3><div class="meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-09T05:00:00-04:00" >June 9, 2022</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack "><div class="td-module-thumb"><a href="https://wallstreetwindow.com/2022/06/2nd-downtown-fridays-to-be-held-in-reidsville-for-rockingham-county-north-carolina-event/" rel="bookmark" class="td-image-wrap " title="2nd Downtown Fridays To Be Held In Reidsville For Rockingham County, North Carolina Event" ><img class="entry-thumb" src="" alt="" title="2nd Downtown Fridays To Be Held In Reidsville For Rockingham County, North Carolina Event" data-type="image_tag" data-img-url="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2022/06/fridays06082022.jpg?resize=100%2C75&ssl=1"  width="100" height="75" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://wallstreetwindow.com/2022/06/2nd-downtown-fridays-to-be-held-in-reidsville-for-rockingham-county-north-carolina-event/" rel="bookmark" title="2nd Downtown Fridays To Be Held In Reidsville For Rockingham County, North Carolina Event">2nd Downtown Fridays To Be Held In Reidsville For Rockingham County,...</a></h3><div class="meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-09T04:57:00-04:00" >June 9, 2022</time></span></div></div></div></div><div class="td-block-span12"><div class="td_module_6 td_module_wrap td-animation-stack "><div class="td-module-thumb"><a href="https://wallstreetwindow.com/2022/06/are-supply-chain-issues-driving-inflation-nicolas-cachanosky/" rel="bookmark" class="td-image-wrap " title="Are Supply Chain Issues Driving Inflation? &#8211; Nicolás Cachanosky" ><img class="entry-thumb" src="" alt="" title="Are Supply Chain Issues Driving Inflation? &#8211; Nicolás Cachanosky" data-type="image_tag" data-img-url="https://i0.wp.com/wallstreetwindow.com/wp-content/uploads/2019/06/fed.jpg?resize=100%2C75&ssl=1"  width="100" height="75" /></a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://wallstreetwindow.com/2022/06/are-supply-chain-issues-driving-inflation-nicolas-cachanosky/" rel="bookmark" title="Are Supply Chain Issues Driving Inflation? &#8211; Nicolás Cachanosky">Are Supply Chain Issues Driving Inflation? &#8211; Nicolás Cachanosky</a></h3><div class="meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-06-09T04:50:00-04:00" >June 9, 2022</time></span></div></div></div></div></div></div></div><div class="td-pb-span4"><div class="td_block_wrap td_block_popular_categories tdi_8 widget widget_categories td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_8" ><h4 class="block-title"><span class="td-pulldown-size">POPULAR CATEGORY</span></h4><ul class="td-pb-padding-side"><li><a href="https://wallstreetwindow.com/category/business-economy/economic-trends/">Economic Trends<span class="td-cat-no">2333</span></a></li><li><a href="https://wallstreetwindow.com/category/stock-market-investing/stock-market-commentary/">Stock Market Commentary<span class="td-cat-no">2093</span></a></li><li><a href="https://wallstreetwindow.com/category/us-and-the-world/us-politics/">US Politics<span class="td-cat-no">2047</span></a></li><li><a href="https://wallstreetwindow.com/category/us-and-the-world/high-and-low-culture/">Culture and Society<span class="td-cat-no">1385</span></a></li><li><a href="https://wallstreetwindow.com/category/us-and-the-world/geopolitics/">Geopolitics<span class="td-cat-no">1277</span></a></li><li><a href="https://wallstreetwindow.com/category/stock-market-investing/technical-analysis/">Technical Analysis<span class="td-cat-no">1174</span></a></li><li><a href="https://wallstreetwindow.com/category/commodities/precious-metals/">Precious Metals Prices<span class="td-cat-no">894</span></a></li></ul></div></div></div></div><div class="td-sub-footer-container td-container td-container-border "><div class="td-pb-row"><div class="td-pb-span8 td-sub-footer-menu"><div class="td-pb-padding-side"><div class="menu-navbar-container"><ul id="menu-navbar-2" class="td-subfooter-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-2828"><a href="https://wallstreetwindow.com/about-us/">About US</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-2602"><a href="https://wallstreetwindow.com/category/stock-market-investing/">Stock Investing</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2603"><a href="https://wallstreetwindow.com/category/stock-market-investing/stock-market-news/">Stock Market News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2604"><a href="https://wallstreetwindow.com/category/stock-market-investing/stock-picks/">Stock Picks</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2605"><a href="https://wallstreetwindow.com/category/stock-market-investing/stock-trading/">Stock Trading Strategies</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2606"><a href="https://wallstreetwindow.com/category/stock-market-investing/technical-analysis/">Technical Analysis</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-2836"><a href="https://wallstreetwindow.com/category/commodities/">Commodities</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2840"><a href="https://wallstreetwindow.com/category/commodities/precious-metals/">Precious Metals Prices</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2837"><a href="https://wallstreetwindow.com/category/commodities/agriculture/">Agriculture and Soft Commodities</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2838"><a href="https://wallstreetwindow.com/category/commodities/energy/">Energy</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2839"><a href="https://wallstreetwindow.com/category/commodities/gold-stocks/">Gold Stocks</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-2841"><a href="https://wallstreetwindow.com/category/business-economy/">Business and Economy</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2844"><a href="https://wallstreetwindow.com/category/business-economy/federal-reserve/">Federal Reserve</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2842"><a href="https://wallstreetwindow.com/category/business-economy/economic-news/">Economic News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2843"><a href="https://wallstreetwindow.com/category/business-economy/economic-trends/">Economic Trends</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2845"><a href="https://wallstreetwindow.com/category/business-economy/marketing/">Marketing</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children td-menu-item td-normal-menu menu-item-2821"><a href="https://wallstreetwindow.com/category/us-and-the-world/">America and the World</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-2825"><a href="https://wallstreetwindow.com/category/us-and-the-world/us-politics/">US Politics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2824"><a href="https://wallstreetwindow.com/category/us-and-the-world/american-empire/">The War State</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2823"><a href="https://wallstreetwindow.com/category/us-and-the-world/geopolitics/">Geopolitics</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2826"><a href="https://wallstreetwindow.com/category/us-and-the-world/the-20th-century/">The Past American Century</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-2822"><a href="https://wallstreetwindow.com/category/us-and-the-world/high-and-low-culture/">Culture and Society</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-39861"><a href="https://wallstreetwindow.com/category/state/">State News</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-39665"><a href="https://wallstreetwindow.com/category/state/north-carolina-news/">North Carolina News</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-39667"><a href="https://wallstreetwindow.com/category/state/virginia-news/">Virginia News</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-2830"><a href="https://www.youtube.com/user/Tradermike2005">Youtube Channel</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-40377"><a href="https://wallstreetwindow.com/two-fold-formula-stock-pick">Subscribe Daily News Digest</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-42055"><a href="https://wallstreetwindow.com/beintheknow-nc-piedmontregion">Subscribe (Greensboro, Winston-Salem, Piedmont NC Region)</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-42054"><a href="https://wallstreetwindow.com/beintheknow-nc-rockinghamcounty">Subscribe (Rockingham County, NC)</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-40375"><a href="https://wallstreetwindow.com/beintheknow">Subscribe (Danville, Martinsville, Halifax VA News)</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-42258"><a href="https://wallstreetwindow.com/republishing-guidelines/">Republishing Guidelines</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-2852"><a href="https://wallstreetwindow.com/contactus">Contact Us</a></li></ul></div></div></div><div class="td-pb-span4 td-sub-footer-copy"><div class="td-pb-padding-side"> &copy; Newsmag WordPress Theme by TagDiv</div></div></div></div></div></div><div id="amp-mobile-version-switcher" hidden> <a rel="" href="https://wallstreetwindow.com/2022/06/big-tech-mounting-big-money-fight-to-defeat-to-corporate-antitrust-bill-andrea-germanos/amp/"> Go to mobile version </a></div> <script type='text/javascript' id='jetpack-lazy-images-js-extra'>var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};</script>  <script type="text/javascript">window._qevents = window._qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

window._qevents.push({
qacct:"p-1aCWHzxdKd-Z6",
uid:"__INSERT_EMAIL_HERE__"
});</script> <noscript><div style="display:none;"> <img src="//pixel.quantserve.com/pixel/p-1aCWHzxdKd-Z6.gif" border="0" height="1" width="1" alt="Quantcast"/></div> </noscript>  <script></script> <script src='https://stats.wp.com/e-202223.js' defer></script> <script>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.0',blog:'147376999',post:'47391',tz:'-4',srv:'wallstreetwindow.com'} ]);
	_stq.push([ 'clickTrackerInit', '147376999', '47391' ]);</script> <script defer src="https://wallstreetwindow.com/wp-content/cache/autoptimize/js/autoptimize_4d9c73952ded87877211ce48c03f0641.js"></script></body></html>
<!-- Dynamic page generated in 1.986 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2022-06-09 23:39:03 -->

<!-- super cache -->